KSDW off air

June 10, Sun
Affected Service: KSDW
  • Investigating
    We are investigating the cause of an outage with KSDW 88.9. Engineers are en route to resolve.

    11:08, Jun 10 PDT
  • Resolved
    Some power issues were identified at the transmitter site. Station is back on the air.

    20:00, Jun 10 PDT
Back to current status