Las Vegas 98.1 off air

March 04, Sun
Affected Service: KWVE-FM
  • Identified
    There is a power outage at the site. We are working to get power restored. It may be the morning before service is restored.

    21:09, Mar 04 PDT
  • Resolved
    Power has been restored and the station is back on the air.

    22:04, Mar 04 PDT
Back to current status